Introducing CalcePWA 4.0

CALCE Electronic Products and Systems Center
University of Maryland
College Park, Maryland 20742
http://www.calce.umd.edu/software/software.html
Starting calcePWA 4.0

Windows version of software is invoked like any other windows application by going to the Start Menu and selecting calcePWA from the launch menu.

CalcePWA, the CALCE Software Update application, and the user documentation can be invoked from the launch menu.
Managing the CCA Virtual Qualification Process

Status of the calcePWA evaluation process can be quickly viewed in this panel.

Modeling

Stress Assessment

Reliability Assessment

Project Selection Bar

CCA Selection Tab

Thumbnail images of CCA
Managing calcePWA Projects

The calcePWA Toolbox organizes the modeling process by creating project directories in which individual CCAs can be created and assessed. The modeling process is facilitated by structural and environmental data managers. Libraries of frequently used data can be viewed and modified by selecting applications from under the Library menu.
Design Menu in calcePWA Toolbox

This menu allows you to create a new design, open an existing design, close an open design, save a design as a new design, delete an existing design. It also provide options directed at the active (top most design panel) design.
Design Panel Pop-Menu

This menu is invoked by selecting the right mouse button when the mouse pointer is over the active design panel. The menu allows you to close, delete, clear (remove data content), create a design archive, restore a design archive, or delete a design archive from the active design.
Flowchart of Design Assessment

Create Design Model

- Conduct Thermal Assessment for Various Operating And Test Conditions
- Conduct Vibration Assessment for Various Operating And Test Conditions

Create Life Cycle Model

- Conduct Failure Assessment for Life Cycle
Importing CAD Data

Import extracts relevant design data from a selected text file in order to create the calcePWA design model.
Supported CAD Text File

• Veribest (New)
• GenCAD (New)
• PADS 1.0, 3.5, 4.0 text files (updated to provide improved scaling)
• Mentor Neutral File
• Cadence IDF file
• Zuken-Recal (CADIF) text files

Import typically provides board outline, part list, component list, and component positions referenced to the board outline. The import procedure was developed by extracting data from example text files.
Importing CAD Data

Import is conducted on the active design.
The PWA design manager provides ability of define and/or modify the PWA model. Functions include ability to define and/or modify board outline, material inserts, layer stack-up, vias, component, part, and materials.
Layer Definition

The construction of the printed wiring board is defined by a layer stack which defines the material composition and the thickness of individual layers that are laminated together to form the printed wiring board. Each layer can be defined as a combination of base material (i.e. dielectric) and metalization (e.g. copper).
Layer Wizard

To facilitate the definition of a printed wiring board lay up, a Layer Wizard has been added to the PWA Layer Manager.
Layer Wizard Results

Selecting the Ok button will produce the following 7 layers board. Note, there will be 13 material layers.
Managing Material Information

A material database is created for each CCA design. This allows the modeler to conduct trade-off studies and evaluate “what if” scenarios.
Material Library

Twenty-four (24) material categories have been added to the material library provided with calcePWA/calceFAST. These categories were taken directly from the CADMP-II software. In addition, the display of the material attributes for individual materials has been separated into six separate categories. Typical material assignments

Via -  Via and PTH
Component – Underfill, package material, die
Lead – Lead and solder balls for BGAs
PWB – Board, Board Inserts
Solder – Interconnect Materials
Semiconductor- Die
Attach- Die attach
Modeling Assembly Data and the Critical Plated Through Hole

The PWA Parameters Manager allows you to define:

- Solder used to form permanent interconnects
- The critical PTH defines the PTH that will be evaluated during failure assessment
Modeling Electrical and Thermal Vias

The electrical and thermal vias are referenced by components and used to enhance thermal conductivity through the board. These structures are managed by the PWA Via Manager.
Modeling Material Inserts

Material inserts may be created by selecting the Insert button on the toolbar or the Edit->Add Insert option from the menu bar.
In many cases, material variations are localized to a region of the printed wiring Board. Examples include holes and additional metallization to promote heat transfer. These can be considered in calcePWA by creating a material insert.
PWA Design Manager: Components

The Board Manager allows you to create and manage components, as well as locate components on the PWB.
Modeling Components

PWA parts manager

PWA material manager

Part ID: U3
Part Name: PLCC64
Placement Side: top
X center location: 47.1 mm
Y center location: 37.84 mm
Placement Orientation: 0.0
Underfill Material: component.air
Standoff height: .4 mm
Solder Joint Height: .1 mm
Solder Joint Bond Area: .3 mm^2
### Component refinement dialog

- **Standoff height:** 0.4 mm
- **Solder Joint Height:** 0.1 mm
- **Solder Joint Bond Area:** 0.3 mm²
- **Thermal Via Count:** 0
- **Thermal Via Ref:**
- **Electrical Via Count:** 64
- **Electrical Via Ref:** Via_2
- **Nominal Power:** 0.4 W

**PWA Via manager**
Managing Component Information

The component spreadsheet manager allows you to view and modify component data, you can update multiple components at once. You can also transfer data to and from common desktop spreadsheet tools such as MS™ Excel.
Components are instances of parts that occur in an assembly. In calcePWA, components references parts. Parts are represented by construction on operation data. Part data is defined by various package templates.
Example of Package Types

- C-Lead Package CLEAD
- Surface Mount Electrolytic Capacitor SMTCAN
- Heat Sink Small Outline Package HSOP
- Column Grid Array Package CGA
- MicroLeadFrame Package HSLCC
- SOT143
Modeling Parts

Part information is categorized to facilitate data entry.
Manipulating Part Data

To facilitate the modeling process, part information can be exported to a text file which can be imported into MS Excel. Once modified, the data can be saved to the CSV (Comma Separated Variable) format and imported back in the calcePWA design model. Note, device data is NOT exported.
Thermal Assessment

Boundary conditions are applied to each layer.

Unassigned Grid Locations are calculated.

Boundary Condition Selection Palette

Flood Fill Toggle Button allows for rapid assignment of boundary conditions at the edge of the board.
Define Analysis Type and Parameters

Thermal Analysis Parameters
[Edit → Parameters]

The parameter dialog in the calcePWA thermal analysis module allows you to select cooling mode and set analysis parameters.
## Cooling Modes modeled in calcePWA

<table>
<thead>
<tr>
<th>Cooling Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Conduction</td>
<td>Internal conduction only</td>
</tr>
<tr>
<td>Conduction_with_NC</td>
<td>Internal conduction, natural convection with assumed vertical orientation.</td>
</tr>
<tr>
<td>Flowover</td>
<td>Internal conduction, surface convection based on defined air flow.</td>
</tr>
<tr>
<td>ColdPlate</td>
<td>Fin Structure Required. Internal conduction. Internal convection to Air in defined fin structure.</td>
</tr>
<tr>
<td>Conduct/HC</td>
<td>Internal conduction, natural convection with assumed horizontal orientation, venting of air assumed.</td>
</tr>
<tr>
<td>Conduct/HCNV</td>
<td>Internal conduction, natural convection with assumed horizontal orientation, no venting of air assumed.</td>
</tr>
<tr>
<td>Conduct/Rad</td>
<td>Internal conduction, surface radiation to enclosure.</td>
</tr>
<tr>
<td>Conduct/Rad/HC</td>
<td>Internal conduction, surface radiation to enclosure, natural convection with assumed horizontal orientation, venting of air assumed.</td>
</tr>
<tr>
<td>Conduct/Rad/HCNV</td>
<td>Internal conduction, surface radiation to enclosure, natural convection with assumed horizontal orientation, no venting of air assumed.</td>
</tr>
</tbody>
</table>

( * Natural Convection is assumed to occur in the y direction (bottom to top as board appears on the screen)
• Power option allows you to modify the total power dissipation level.
• Component Data option allows you to modify individual component power.
To conduct the analysis, you must save the thermal model. If you make changes to the design model outside the Thermal Manager, you will need to select the *File->Capture* option to update the existing thermal model with current design model.
Display of Thermal Analysis Results

CalcePWA Display Tool presents the results of a thermal analysis.

Cross-Section Plot

Tabular view of component information
Determining Component Temperatures

Substrate Temperatures

\[ T_{\text{sub}} = T_{\text{layer}} + QR_z \]

\( T_{\text{layer}} \) -- Layer temperature below component

\( R_z = \frac{0.5 \Delta Z}{K_A} \)

\( A_c \) -- Planar component area

Case Temperatures

\[ T_{\text{case}} = T_{\text{sub}} + QR_{\text{case}} \]

\( R_{\text{case}} \) -- Parallel resistance of leads and case to substrate

Junction Temperatures

\[ T_{\text{junction}} = T_{\text{case}} + Q\Theta_{jc} \]

\( \Theta_{jc} \) -- User specified

The display tool shows component temperatures calculated from the thermal analysis.
The vibration analysis manager is based on the Advanced Vibration Manager from calcePWA 3.3. The menu and interface capabilities have been updated to increase ease of use.
Application of Support and Static Loading to the PWA

Left mouse button to select or create a boundary condition or load condition.

Right mouse button invoke refine dialog
Cutline Mode

The cutline mode is used to define the grid by which the elements will be formed.
Creating the Finite Element Model from Specified Boundary Conditions

The finite element mesh is automatically created when you switch from the Cutlines mode to the FEM mode. You can also use the \textit{FEM->Create FEM} option to force the creation of the FE model.
Selecting Loading Condition

To run an analysis, you must define the load type and save the problems.

Selecting “Run” button begins analysis procedure

• Data is checked for consistency
• Analysis input files are generated
• Analysis programs are executed

• Static Load Type is only valid if you have defined a static loading condition. Note Static Loading conditions are NOT considered in the Random or Shock analysis

*Edit-*->Loading
Evaluating the mode shape and modal frequencies with an input power spectral density (PSD) curve allows software to calculate random response, board displacement and curvature. Note: PSD curve should be limited to approximately 10 points.
The shock analysis determines the maximum response of the assembly based on a defined shock loading condition. The shock loading condition is defined as presented above.
Saving and Updating the Design Model

To conduct the analysis, you must save the vibration model. If you make changes to the design model outside the Vibration Manager, you will need to select the **File->Capture** option to update the existing vibration model with current design model.
Displaying Advanced Vibration Analysis Results

Analysis results include:
Mode Shapes,
Natural Frequencies,
Board Displacement,
Board Curvature,
Component Displacement, and
Component Curvatures
Defining the Life Cycle Profile

This tool allows you to define multiple loading conditions over which that PWA can be analyzed.
Specifying Loading Condition Segments

Has Fixed Duration: No

Fixed Cycles: 1

Temperature Cycles Per Day: 2

Max Temp. Thermal Results: Test

Min. Temp. Source: User Defined

Min. Comp Temp: -55 degC

Min. Board Temp: -55 degC

Min Temp. Thermal Results: Test

Advanced Vib. Results: Test

Has Fixed Duration: Yes

Fixed Hours: 10

Loading condition may have a fixed period or occur periodically over life of the product.

When creating loading conditions for use in failure analysis, you will be able to choose from the available thermal and vibration analysis results.
Creating the Life Cycle Stress Profile Database

1. Define Profile Loading Conditions
2. Define the overall application period
3. Save Profile Definition
4. Generate the Life Cycle Stress Profile Database

Once the individual stress segments have been defined, you will need to define the application period over which the stress segments will be applied and then generate the Life Cycle Stress Profile Database.
Conducting PWA Failure Analysis

CalcePWA provides an integrated failure assessment capability that allows you to perform failure assessment based on user defined stress conditions with selected failure models.
Selecting Failure Models

The PWA Failure Analysis Manager automatically selects failure sites based on a list of available failure models, the selected life cycle stress profile database (LCSPDB), and the selected failure assessment mode.
Running the Analysis and Viewing the Results

Once the Life Profile and Failure Models and Sites have been selected, save the analysis problem to file and start the analysis by selecting the **Evaluate** button.
General Motors Requires VQ


4.1.4.1.3 Thermal-Mechanical Cycling Stress, Transmission, and Fatigue Durability.

Purpose. This is a Physics of Failure analysis ….

Procedure. Identify the leaded and leadless components on the circuit board that are "most at risk“ … Using analytical methods… Tools …

1) CALCE-PWA (University of Maryland),
CalcePWA Predicts Accurate Vibration Response for Lockheed Martin Boards

CALCE Physics of Failure Simulation Results

<table>
<thead>
<tr>
<th>Board</th>
<th>HDLC</th>
<th>MAX708</th>
<th>1553</th>
<th>DIO</th>
<th>7404</th>
<th>Flash</th>
<th>SDRAM</th>
</tr>
</thead>
<tbody>
<tr>
<td>CALCEPWA</td>
<td>447 Hz</td>
<td>813 Hz</td>
<td>342 Hz</td>
<td>475 Hz</td>
<td>311 Hz</td>
<td>1142 Hz</td>
<td>1252 Hz</td>
</tr>
<tr>
<td>Test</td>
<td>420 Hz</td>
<td>725 Hz</td>
<td>320 Hz</td>
<td>470 Hz</td>
<td>Not Run</td>
<td>Not Run</td>
<td>Not Run</td>
</tr>
</tbody>
</table>

- Simulated Vibration Results Achieve 1% to 12% Accuracy
- Thermal Analysis Consistent with Test Board Measurements
- Accurate Solder Fatigue Failure Results

“Software is being used to help evaluate designs. Software provides a definite cost benefit to our design process.”
Validated against Measured Test Results

**Vibration Analysis Results**

<table>
<thead>
<tr>
<th>Component</th>
<th>1st Natural Frequency (Hz)</th>
<th>1st Natural Frequency (Hz)</th>
<th>Max. Displacement (mils)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>CALCE</strong></td>
<td><strong>SEI ESS</strong></td>
<td><strong>Test Data</strong></td>
</tr>
<tr>
<td>Video Processor CCA</td>
<td>372</td>
<td>510</td>
<td>.33</td>
</tr>
<tr>
<td>Power Filter CCA</td>
<td>226</td>
<td>230</td>
<td>13.5</td>
</tr>
<tr>
<td>Processor CCA</td>
<td>248</td>
<td>265</td>
<td>.47</td>
</tr>
<tr>
<td>Interface CCA</td>
<td>303</td>
<td>265</td>
<td>.66</td>
</tr>
<tr>
<td>Serial I/O CCA</td>
<td>261</td>
<td>N/A*</td>
<td>.61</td>
</tr>
<tr>
<td>Backplane CCA</td>
<td>417</td>
<td>410</td>
<td>.04</td>
</tr>
</tbody>
</table>

The vibration analysis software in calcePWA has been extensively validated against experimental data and numerical simulations.

*Input frequency to Solder Joint Fatigue is lowest value of CALCE results and ESS test results*
Validation of CalcePWA Vibration Analysis

Modal Analysis & Displacement

ANSYS

Resonant Frequencies
710 Hz
1331 Hz
1444 Hz

calcePWA

Resonant Frequencies
724 Hz
1348 Hz
1399 Hz
CalcePWA Software Assessment (Military Radio)

**Objectives:**
- Assess reliability of Control Module in the military environment
- Improve reliability of Control Module

**Testing Results:**
- 20 pin Leadless Chip Carrier (LCC) was weak in design
- Estimated life under operating conditions - 6.5 years

**Analysis Results:**
- Developed Log Case Study for Potential Improvements
  - Module Level - 5,000 units fielded - 20 years field life

Testing of CCAs demonstrated failures predicted by CalcePWA Analysis. Redesign of module results in an estimated savings of $27M in avoided cost.
Successful Application of calcePWA
Design-Build-Test-Fix vs. Simulation Assisted Design

**Program Comparison:**

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Moderate</td>
<td>Proven Tech/Compts - No Electromech.</td>
<td>Low Power/Heat</td>
<td>I.P. Mounted Snap Fit, 1 conn.</td>
<td>Supplier A - Highly Capable</td>
</tr>
<tr>
<td>(Development Period - 130 Wks)</td>
<td>More Complex</td>
<td>Proven Tech/Compts +4 Onboard Relays</td>
<td>High Power &amp; Thermal Challenges</td>
<td>Supplier A - Highly Capable</td>
</tr>
<tr>
<td>(Development Period - 109 Wks)</td>
<td></td>
<td></td>
<td>Console Mnt., Integ’t’d w/Fuse (NEW)</td>
<td></td>
</tr>
</tbody>
</table>

**Results:**

- Completed 1/98
- 16
- Completed 8/99
- 6

• Product development using simulations produced a more robust design, in less time.
• First pass issue reductions: 100% E/E circuits, 83% permanent failures, 75% EMI, 63% total
• The more complex module, using the simulated assisted design, achieved higher quality, durability, and reliability by beta version in a shorter period.
The calcePWA software has been used to assess remaining life assessment of circuit boards used in avionic and space applications.